Mars Software Forum
http://www.mars-soft.net/forum/

Pasting HTML doesn't work right
http://www.mars-soft.net/forum/viewtopic.php?f=2&t=3125
Page 1 of 1
Author:  Dustydharma [ Sat Jun 04, 2011 4:16 pm ]
Post subject:  Pasting HTML doesn't work right

I'm a new user of this notebook and perhaps don't understand some settings, but I bought this primarily to save various things from web pages including links and pictures and text. I tried copying part of a page about Swedish authors and pasting it into the notebook. It had several links but when I hovered the mouse over them the cursor didn't change and they simply weren't clickable . Also the text was messed up wherever it had mutated Swedish vowels! I pasted with normal paste and "paste as" html with the same bad results. Here is the page I used to copy from : http://www.scandinavianbooks.com/crime- ... ahloo.html
Any help or suggestions appreciated. I really love this program except for this major problem. Thanks !
Author:  Marsianin [ Sun Jun 05, 2011 11:56 am ]
Post subject:  Re: Pasting HTML doesn't work right

As indicated in short FAQ which is available when no database loaded or no sections selected you can click on the links with CTRL pressed or switch to read-only mode and click links without CTRL key.

HTML is not saved as is, it's converted to an editable format. Program is fully Unicode so everything should work fine. I will check this page and let you know.
Author:  Marsianin [ Sun Jun 05, 2011 7:01 pm ]
Post subject:  Re: Pasting HTML doesn't work right

Just tried to paste this page. Everything works fine here. Try to use v.2.1 RC2 (available here at the forum).
Author:  Dustydharma [ Mon Jun 06, 2011 4:24 pm ]
Post subject:  Re: Pasting HTML doesn't work right

I have now reinstalled Notebook and tried again to copy and paste from the site I listed above
and still get a bunch of garbage ??? plus black diamonds with ? inside !! Can someone please
help me get this program to copy properly ? I am using Win 7 with normal default setup. I have
most of the critical updates but have not installed service pac 1, however, I can't believe my system
is the problem because I can paste the same website into other programs with no issue . It is only
Mars Notebook that does this text problem ( something to do with Unicode I guess because if I copy
and paste using "paste with unicode" then the text is ok but the pictures and links don't show up.)
Yes, I am using the latest version of Mars Notebook 2.1RC2 posted on this web site. I would appreciate
any suggestions. By the way, is this 2.1 RC2 a beta ? The link at the Mars Notebook website for
downloads says v.2.0. Maybe I should try that ?
Author:  Marsianin [ Mon Jun 06, 2011 7:47 pm ]
Post subject:  Re: Pasting HTML doesn't work right

2.1 RC2 is a 2.1 release candidate which will be available in a couple of days.
I tried your webpage and it works fine here. Please provide me more examples to test it more carefully.
And it's not a Windows problem.
Page 1 of 1 All times are UTC - 5 hours