Page 1 of 1

100% CPU

Posted: Tue Aug 09, 2011 1:20 pm
by Leo

I have been using Mars Notebook for a long time and it is great. Recently I've had a problem with my CPU going to 100% due to Mars Notebook, even when I'm not doing anything, and it stays at 100% for a long long time (minutes) - the problem is definitely Notebook because when I use 'File-Exit' then the CPU returns to normal...

I have already tried Database-Compact and Database-Repair but the problem still happens. I have 178 sections, 0 attachments, file size 6 Mb, no encryption.

Do you have any idea why this is happening?


Re: 100% CPU

Posted: Tue Aug 09, 2011 1:26 pm
by Marsianin
Hm...very strange. What version of Mars Notebook and Windows you're using?
And does it happen just right after the program starts or some special event?
Did you install some new software or something...

Re: 100% CPU

Posted: Tue Aug 09, 2011 1:40 pm
by Leo
Windows XP

Mars Notebook v2.0 (that's what it says in the 'About' box)

No new programs recently installed.

It never happens when the program starts, it just happens at random times - sometimes it happens when I have Notebook open and am using it, but other times when I have been using Notebook recently and then I minimize it to the tray then the problem happens soon after, and sometimes it happens when I haven't been using Notebook recently and it is just sitting in the system tray.

I wonder if it could be my anti-virus program (Avast), it never caused a problem in the past but maybe something changed... I will try adding the database file to the 'exclusions' list so it won't be scanned at all.

Re: 100% CPU

Posted: Tue Aug 09, 2011 2:32 pm
by Marsianin
Try to use Mars Notebook 2.1 RC3 from this forum...

Re: 100% CPU

Posted: Mon Aug 22, 2011 10:51 am
by Leo
I tried RC3 but still noticed the problem sometimes.

Now I have maybe found the problem, well at least I found one situation where the problem can be reproduced every time, I don't know if there are also other situations where the problem happens. It's quite easy to see CPU go to 100%, just follow these simple steps :

(1) In preferences, select "Check spelling as you type".

(2) Click the icon for 'Add Section' or 'Add Subsection', or do the same from the Section menu.

(3) Watch the CPU jump to 100%, it will stay at 100% permanently - until something is typed in the new section.

I also tested with different dictionaries (and autocorrect dictionaries) but it didn't seem to make a difference.

Well at least I now found a solution, when I create a new section I just have to start typing in it immediately! I don't know if this is the only problem that causes the 100% CPU, but it makes sense because in the past I never had this 100% CPU problem and I wasn't using the auto spelling checker, now recently I started using the auto spelling checker and I guess the new CPU problem started around the same time.

Also please don't forget about the other problem I reported with the spelling suggestions list having hundreds of suggestions causing it to take ages to scroll to the options.

Looking forward to RC4 :)


Re: 100% CPU

Posted: Mon Aug 22, 2011 2:07 pm
by Marsianin
Ok, thanks. I will check this out. Looks like this spellchecker is quite buggy.